aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2020-11-09 12:25:05 +0000
committerJim Flynn <jim.flynn@arm.com>2020-11-10 16:50:49 +0000
commit0d35a93d68e321e8c4b16baa8b9754b98cc9faf3 (patch)
treed4143415dbd8d7ea2b65b802fe9e18ead9a09e75 /delegate/CMakeLists.txt
parent8b9858d891439fd1b0710e5d245e2116a3b88d30 (diff)
downloadarmnn-0d35a93d68e321e8c4b16baa8b9754b98cc9faf3.tar.gz
IVGCVSW-5398 TfLiteDelegate: Implement the Quantization operators
* Enabled quantization operators DEQUANTIZE and QUANTIZE. * Implemented unit tests for quantization operators. * Added utils function for checking if affine quantization. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I84b5c75bda629d9234f5ed198b04f527705a54aa
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 814976407b..0a1a3e43e4 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -94,7 +94,9 @@ list(APPEND armnnDelegate_unittest_sources
src/test/ElementwiseBinaryTest.cpp
src/test/ElementwiseBinaryTestHelper.hpp
src/test/ElementwiseUnaryTest.cpp
- src/test/ElementwiseUnaryTestHelper.hpp)
+ src/test/ElementwiseUnaryTestHelper.hpp
+ src/test/QuantizationTest.cpp
+ src/test/QuantizationTestHelper.hpp)
add_executable(DelegateUnitTests ${armnnDelegate_unittest_sources})
target_include_directories(DelegateUnitTests PRIVATE src)