aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2020-11-30 17:43:28 +0000
committerJim Flynn <jim.flynn@arm.com>2020-12-17 15:34:55 +0000
commit019840d1161738aefd6ebd32ccf4e72e618cae15 (patch)
tree4448bfb2e5d395e739cf11f66c8644b69e3874fd /delegate/CMakeLists.txt
parentc11ba468017b8b06c5c0f83743575d34bad1dd3b (diff)
downloadarmnn-019840d1161738aefd6ebd32ccf4e72e618cae15.tar.gz
IVGCVSW-5374 Provide an Android build for the delegate
Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I33eb8c650be654ad891afd2295f2057f13a9d084
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 5303d81d26..9be2f44d44 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -71,10 +71,10 @@ add_library(tflite_headers INTERFACE)
target_include_directories(tflite_headers INTERFACE $<BUILD_INTERFACE:${TfLite_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include/tflite_headers>)
-target_compile_options(tflite_headers INTERFACE $<$<CXX_COMPILER_ID:GNU>:-Wno-conversion
- -Wno-sign-conversion
- -Wno-unused-parameter
- -Wno-unused-function>)
+target_compile_options(tflite_headers INTERFACE -Wno-conversion
+ -Wno-sign-conversion
+ -Wno-unused-parameter
+ -Wno-unused-function)
target_link_libraries(armnnDelegate PUBLIC tflite_headers)
@@ -89,7 +89,7 @@ target_link_libraries(armnnDelegate PRIVATE
add_library(flatbuffer_headers INTERFACE)
target_include_directories(flatbuffer_headers INTERFACE $<BUILD_INTERFACE:${Flatbuffers_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include/flatbuffer_headers>)
-target_compile_options(flatbuffer_headers INTERFACE $<$<CXX_COMPILER_ID:GNU>:-Wno-sign-conversion>)
+target_compile_options(flatbuffer_headers INTERFACE -Wno-sign-conversion)
target_link_libraries(armnnDelegate PUBLIC flatbuffer_headers)