aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2019-09-05 10:03:56 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-09-06 12:13:51 +0000
commit366023fcb63d0ade5bd742ede2fc27899296877c (patch)
tree9c940e53ff15d31461f6c44067dcaf41c1a181f4 /CMakeLists.txt
parent07882f1750f0ff83a955fe8e9c363ca26059f084 (diff)
downloadarmnn-366023fcb63d0ade5bd742ede2fc27899296877c.tar.gz
IVGCVSW-3719 Create test program executable.
Introduce a new test utility that simulates the Gatord service. This will be used to test the external profiling features. Change-Id: Ib7c75c1302650e140945cd66d272c23af3aac760 Signed-off-by: Colm Donelan <Colm.Donelan@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef87c6d1fc..b29a709643 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -818,3 +818,22 @@ if (BUILD_ARMNN_SERIALIZER AND (BUILD_TF_PARSER OR BUILD_TF_LITE_PARSER OR BUILD
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(ArmnnConverter)
endif()
+
+if(BUILD_GATORD_MOCK)
+ set(gatord_mock_sources)
+ list(APPEND gatord_mock_sources
+ tests/profiling/GatordMockMain.cpp
+ tests/profiling/CommandLineProcessor.hpp
+ tests/profiling/CommandLineProcessor.cpp
+ )
+
+ include_directories( ${Boost_INCLUDE_DIRS} )
+
+ add_executable_ex(GartordMock ${gatord_mock_sources})
+
+ target_link_libraries(GartordMock
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ )
+
+endif()
+