aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2020-02-05 17:48:59 +0000
committerColm Donelan <colm.donelan@arm.com>2020-02-07 09:28:35 +0000
commit1aff393b359b518925f66901439466f9bc14c49d (patch)
tree9d31aa1d3dabb4b637093f6fd1a9f1549621c653 /CMakeLists.txt
parent3446057492907d0c7695605a5b9a961a78158d7e (diff)
downloadarmnn-1aff393b359b518925f66901439466f9bc14c49d.tar.gz
IVGCVSW-4317 Implement the Profiling Context Initialisation
* Call CreateBackendProfilingContext on each backend from Runtime passing an instance of the BackendProfiling interface. * Modify the signature of CreateBackendProfilingContext to remove const and return a shared_ptr to BackendProfilingContext * Add concrete BackendProfiling class. * Store BackendProfilingContexts in Profiling service. Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: I975eaa2093ae91fa623835f65f9e5b25eb65117a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 950ad4a946..38566639b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -515,6 +515,8 @@ list(APPEND armnn_sources
src/profiling/TimelinePacketWriterFactory.hpp
src/profiling/TimelineUtilityMethods.cpp
src/profiling/TimelineUtilityMethods.hpp
+ src/profiling/backends/BackendProfiling.cpp
+ src/profiling/backends/BackendProfiling.hpp
third-party/half/half.hpp
)