aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNarumol Prangnawarat <narumol.prangnawarat@arm.com>2019-11-22 11:26:06 +0000
committerJim Flynn Arm <jim.flynn@arm.com>2019-11-29 17:01:45 +0000
commitdf31cfe29f9dccc4c2055a1d2a97de644b07d522 (patch)
tree15e848d398c35e669ecb0cff574907c4bd1662b9 /CMakeLists.txt
parenta68d8530d3dcfc7c54b9c2bfa00b407f45145253 (diff)
downloadarmnn-df31cfe29f9dccc4c2055a1d2a97de644b07d522.tar.gz
IVGCVSW-4070 Implement "send post-optimized network structure"
* Send post-optimisation network structure if profiling service is enabled * Refactor TimelineUtilityMethods * Fix RecordEvent to link eventGuid with eventClassGuid * Add common types and guid to LabelsAndEventClasses * Add CreateRelationship to TimelineUtilityMethods * Add CreateTypedEntity to TimelineUtilityMethods * Add MarkEntityWithType to TimelineUtilityMethods * Move VerifyTimeline functions to ProfilingTestUtils * Post-optimisation network structure unit tests to Ref, Cl, Neon Signed-off-by: Narumol Prangnawarat <narumol.prangnawarat@arm.com> Change-Id: I0194f2037c236450c912f4c3cb11e46b80c0f512
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad9e9ee91d..7b6e1ab980 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -632,6 +632,8 @@ if(BUILD_UNIT_TESTS)
src/profiling/test/ProfilingGuidTest.cpp
src/profiling/test/ProfilingTests.cpp
src/profiling/test/ProfilingTests.hpp
+ src/profiling/test/ProfilingTestUtils.cpp
+ src/profiling/test/ProfilingTestUtils.hpp
src/profiling/test/SendCounterPacketTests.cpp
src/profiling/test/SendCounterPacketTests.hpp
src/profiling/test/SendTimelinePacketTests.cpp