aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2020-02-02 12:52:59 +0000
committerDavid Monahan <david.monahan@arm.com>2020-02-03 14:51:47 +0000
commit9789702c0b276ca9518e590f30465da7e76a940f (patch)
tree08f3090bb8e22e84349253b8c924d626742f02f0 /CMakeLists.txt
parent8e0c7a66efc8d61787c43cdaeab3754e2905f623 (diff)
downloadarmnn-9789702c0b276ca9518e590f30465da7e76a940f.tar.gz
IVGCVSW-4393 Register backend counters
Signed-off-by: David Monahan <david.monahan@arm.com> Change-Id: I419ecc2fce4b7e0fcaeb6d1f9cb687c0b660125d Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c811ee5b54..950ad4a946 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -470,6 +470,7 @@ list(APPEND armnn_sources
src/profiling/Holder.hpp
src/profiling/IBufferManager.hpp
src/profiling/ICounterDirectory.hpp
+ src/profiling/ICounterRegistry.hpp
src/profiling/ICounterValues.hpp
src/profiling/ISendCounterPacket.hpp
src/profiling/IPacketBuffer.hpp
@@ -500,6 +501,8 @@ list(APPEND armnn_sources
src/profiling/ProfilingStateMachine.hpp
src/profiling/ProfilingUtils.cpp
src/profiling/ProfilingUtils.hpp
+ src/profiling/RegisterBackendCounters.cpp
+ src/profiling/RegisterBackendCounters.hpp
src/profiling/RequestCounterDirectoryCommandHandler.cpp
src/profiling/RequestCounterDirectoryCommandHandler.hpp
src/profiling/SendCounterPacket.cpp