aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2020-01-24 16:27:02 +0000
committerColm Donelan <Colm.Donelan@arm.com>2020-01-28 12:01:42 +0000
commit5ccb33da0565e0bf2279318f1e7ad597afcc0367 (patch)
tree0266241d45ea8d0b0055c78ee0f28ee8cbc3a462 /CMakeLists.txt
parent03b6b410321923bac7ed2eb1507f524953c9a464 (diff)
downloadarmnn-5ccb33da0565e0bf2279318f1e7ad597afcc0367.tar.gz
IVGCVSW-4316 Promote ISendTimelinePacket and IProfilingGuidGenerator
As part of IVGCVSW-4316 we need to expose ISendTimelinePacket and IProfilingGuidGenerator to enable them to be used by backends for profiling. This also required moving ProfilingRelationshipType from ProfilingUtils. Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: I58cc64e32ecfffa5231c9d2028522ed58d0ddf31
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c8c3870c2..b1af90d8af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,6 +242,8 @@ list(APPEND armnn_sources
include/armnn/TypesUtils.hpp
include/armnn/Utils.hpp
include/armnn/Version.hpp
+ include/armnn/profiling/IProfilingGuidGenerator.hpp
+ include/armnn/profiling/ISendTimelinePacket.hpp
src/armnn/layers/LayerCloneBase.hpp
src/armnn/layers/LayerWithParameters.hpp
src/armnn/layers/ActivationLayer.hpp
@@ -468,12 +470,10 @@ list(APPEND armnn_sources
src/profiling/ICounterDirectory.hpp
src/profiling/ICounterValues.hpp
src/profiling/ISendCounterPacket.hpp
- src/profiling/ISendTimelinePacket.hpp
src/profiling/IPacketBuffer.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
src/profiling/IProfilingConnectionFactory.hpp
- src/profiling/IProfilingGuidGenerator.hpp
src/profiling/LabelsAndEventClasses.cpp
src/profiling/LabelsAndEventClasses.hpp
src/profiling/Packet.hpp