aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2022-01-23 23:57:20 +0000
committerJim Flynn <jim.flynn@arm.com>2022-02-14 09:51:24 +0000
commit4c9ed1d974657b8b32c8a86239c105ca54b30be5 (patch)
tree9f3d59d9626f333e3626c61d17ab984692e43c86 /CMakeLists.txt
parentd688e86c5edf19b2de556d198d6cb8688c6919da (diff)
downloadarmnn-4c9ed1d974657b8b32c8a86239c105ca54b30be5.tar.gz
IVGCVSW-6708 Break Profiling Dependence on IRuntime ExternalProfilingOptions
Change-Id: I30a46f3368bbbf33019eac4fa1245f6ff69deacd Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ba5985efd..9e115719cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,6 +106,8 @@ list(APPEND armnnUtils_sources
src/armnnUtils/ParserPrototxtFixture.hpp
src/armnnUtils/Processes.hpp
src/armnnUtils/Processes.cpp
+ src/armnnUtils/ProfilingOptionsConverter.hpp
+ src/armnnUtils/ProfilingOptionsConverter.cpp
src/armnnUtils/PrototxtConversions.hpp
src/armnnUtils/PrototxtConversions.cpp
src/armnnUtils/TensorIOUtils.hpp
@@ -178,6 +180,7 @@ list(APPEND armnn_sources
include/armnn/Utils.hpp
include/armnn/Version.hpp
include/armnn/profiling/ISendTimelinePacket.hpp
+ include/armnn/profiling/ProfilingOptions.hpp
include/armnn/utility/Assert.hpp
include/armnn/utility/IgnoreUnused.hpp
include/armnn/utility/NumericCast.hpp