aboutsummaryrefslogtreecommitdiff
path: root/python/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyproject.toml')
-rw-r--r--python/pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/python/pyproject.toml b/python/pyproject.toml
new file mode 100644
index 0000000000..720f60d589
--- /dev/null
+++ b/python/pyproject.toml
@@ -0,0 +1,15 @@
+[tool.black]
+line-length = 120
+exclude = '''
+(
+ /(
+ \.eggs # exclude a few common directories in the
+ | \.git # root of the project
+ | \.mypy_cache
+ | \.venv
+ | \.vscode
+ | \.pytest_cache
+ | build
+ )
+)
+'''