aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index f739824402..3bc2aeda63 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -43,6 +43,7 @@ message(STATUS "${CMAKE_PROJECT_NAME} ${CMAKE_PROJECT_VERSION}")
option(CKW_ENABLE_OPENCL "Enable OpenCL code generation" OFF)
option(CKW_ENABLE_ASSERTS "Enable assertions. Always enabled in Debug builds" OFF)
option(CKW_BUILD_TESTING "Build the Compute Kernel Writer validation test suite" OFF)
+option(CKW_BUILD_PROTOTYPE "Build the prototype implementation of kernel writer." OFF)
option(CKW_CCACHE "Use compiler cache for faster recompilation" OFF)
#---------------------------------------------------------------------
@@ -105,6 +106,7 @@ target_compile_options(ckw
# Set CMAKE_CXX_FLAGS last so user can overwrite options
${CMAKE_CXX_FLAGS}
PRIVATE
+ # Always optimize for binary size
$<$<CONFIG:Release>:-Os>
)