aboutsummaryrefslogtreecommitdiff
path: root/python/pyproject.toml
diff options
context:
space:
mode:
authorGeorgios Pinitas <georgios.pinitas@arm.com>2021-08-17 12:54:59 +0100
committerFreddie Liardet <frederick.liardet@arm.com>2021-09-27 16:29:06 +0000
commita71711008dad9a786a66dcd734b19cb102d65ec5 (patch)
treed452f581cedde72a61867680be4d290adb03beba /python/pyproject.toml
parent93d6cf0028aea111f624b320027576a26354e998 (diff)
downloadComputeLibrary-a71711008dad9a786a66dcd734b19cb102d65ec5.tar.gz
Generate an operator configuration file from a list of tflite models
Signed-off-by: Georgios Pinitas <georgios.pinitas@arm.com> Change-Id: I1b13da6558bd11d49747162d66c81255ccec1498 Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/6166 Tested-by: Arm Jenkins <bsgcomp@arm.com> Reviewed-by: SiCong Li <sicong.li@arm.com> Reviewed-by: Sheri Zhang <sheri.zhang@arm.com> Comments-Addressed: Arm Jenkins <bsgcomp@arm.com>
Diffstat (limited to 'python/pyproject.toml')
-rw-r--r--python/pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/python/pyproject.toml b/python/pyproject.toml
new file mode 100644
index 0000000000..720f60d589
--- /dev/null
+++ b/python/pyproject.toml
@@ -0,0 +1,15 @@
+[tool.black]
+line-length = 120
+exclude = '''
+(
+ /(
+ \.eggs # exclude a few common directories in the
+ | \.git # root of the project
+ | \.mypy_cache
+ | \.venv
+ | \.vscode
+ | \.pytest_cache
+ | build
+ )
+)
+'''