aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorGian Marco Iodice <gianmarco.iodice@arm.com>2023-07-07 11:25:57 +0100
committerViet-Hoa Do <viet-hoa.do@arm.com>2023-07-20 08:48:15 +0000
commitebfdb5a1ea73c2269eec5af492970c2174ab7d0f (patch)
tree5c60d083100118f0a40e629dfa69b7a7373dd7fd /compute_kernel_writer/CMakeLists.txt
parent29dc9fc1d3d6e90746ba1173e3318b774dcf7bed (diff)
downloadComputeLibrary-ebfdb5a1ea73c2269eec5af492970c2174ab7d0f.tar.gz
Integrate CLTensorArgument
- Add CLTensorArgument to query the components and storages as OpenCL variables (or by values when possible) - Add caching mechanism in CLTensorArgument to keep track of the components and storages used - Add unit tests Resolves COMPMID-5787 Signed-off-by: Gian Marco Iodice <gianmarco.iodice@arm.com> Signed-off-by: Viet-Hoa Do <viet-hoa.do@arm.com> Change-Id: Ib39e1f77b097e5b907a296fe6b0d41bb4bcd4ffc Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9908 Comments-Addressed: Arm Jenkins <bsgcomp@arm.com> Benchmark: Arm Jenkins <bsgcomp@arm.com> Tested-by: Arm Jenkins <bsgcomp@arm.com> Reviewed-by: Gunes Bayir <gunes.bayir@arm.com> Reviewed-by: Jakub Sujak <jakub.sujak@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index 9f372df585..674bc53309 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -131,6 +131,7 @@ target_sources(ckw PRIVATE
if(CKW_ENABLE_OPENCL)
target_sources(ckw PRIVATE
src/cl/CLConstantTile.cpp
+ src/cl/CLTensorArgument.cpp
src/cl/CLHelpers.cpp
src/cl/CLTile.cpp
src/cl/ICLTile.cpp
@@ -150,11 +151,6 @@ if(CKW_BUILD_TESTING)
add_executable(ckw_validation
validation/Validation.cpp
)
- if(CKW_ENABLE_OPENCL)
- target_sources(ckw_validation PRIVATE
- validation/tests/CLConstantTileTest.hpp
- validation/tests/CLTileTest.hpp)
- endif()
target_link_libraries(ckw_validation PRIVATE ckw)
target_include_directories(ckw_validation