aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorGunes Bayir <gunes.bayir@arm.com>2023-07-25 22:32:05 +0100
committerGunes Bayir <gunes.bayir@arm.com>2023-08-07 14:05:49 +0000
commit5e842512d1f1f47a61df56556f33625e071704c3 (patch)
treec43a69727673a61862c887659bff8fb6547fc4cc /compute_kernel_writer/CMakeLists.txt
parente1c96e7e6dbf5314676fc81831e2ccb34a031ea1 (diff)
downloadComputeLibrary-5e842512d1f1f47a61df56556f33625e071704c3.tar.gz
Add Tensor3dMapper to CKW
In CKW, tensors are assumed to be 3d, except the batch dimension. Tensor3dMapper class defines how an Nd tensor is mapped to 3d. It also provides utility functions to access certain dimensions and the associated strides. Partially Resolves: COMPMID-5791 Signed-off-by: Gunes Bayir <gunes.bayir@arm.com> Change-Id: I17c176220201ff92954ab5808fa1c1f29966d4e9 Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9993 Benchmark: Arm Jenkins <bsgcomp@arm.com> Reviewed-by: Jakub Sujak <jakub.sujak@arm.com> Comments-Addressed: Arm Jenkins <bsgcomp@arm.com> Tested-by: Arm Jenkins <bsgcomp@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index 9a97563025..8f896ef35f 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -122,6 +122,7 @@ target_sources(ckw PRIVATE
src/Helpers.cpp
src/Kernel.cpp
src/KernelWriter.cpp
+ src/Tensor3dMapper.cpp
src/TensorInfo.cpp
src/TensorOperand.cpp
src/TensorSampler.cpp