aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorGunes Bayir <gunes.bayir@arm.com>2023-07-12 14:50:56 +0100
committerGunes Bayir <gunes.bayir@arm.com>2023-07-12 15:23:55 +0000
commit3c776066a0195f2e99d3503f8b058e468d53b884 (patch)
treef91268d28eed0a3446330385185898f6d6aa17f6 /compute_kernel_writer/CMakeLists.txt
parent945b8da90cea5ccacc0294e58131f73f39137367 (diff)
downloadComputeLibrary-3c776066a0195f2e99d3503f8b058e468d53b884.tar.gz
Rename ITileOperand and introduce vector/scalar interfaces in CKW
Partially Resolves: COMPMID-5788 This patch - renames ITileOperand to TileOperand, which seems to be a more intuitive name for the prospective users of Compute Kernel Writer - provides IScalarAccess and IVectorAccess interfaces to be used by Tile classes. It replaces the current IScalarTile and IVectorTile, and forms a more intuitive inheritance hierarchy where each subclass "is a" member of the parent class semantically. Signed-off-by: Gunes Bayir <gunes.bayir@arm.com> Change-Id: I2b5253b0595e63f8ff3047c608d593b3b364634d Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9910 Reviewed-by: Jakub Sujak <jakub.sujak@arm.com> Reviewed-by: Viet-Hoa Do <viet-hoa.do@arm.com> Comments-Addressed: Arm Jenkins <bsgcomp@arm.com> Benchmark: Arm Jenkins <bsgcomp@arm.com> Tested-by: Arm Jenkins <bsgcomp@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index d763bc6de5..9f372df585 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -120,12 +120,12 @@ target_compile_definitions(ckw PUBLIC
target_sources(ckw PRIVATE
src/Error.cpp
src/Helpers.cpp
+ src/Kernel.cpp
+ src/KernelWriter.cpp
src/TensorInfo.cpp
src/TensorUtils.cpp
src/TileInfo.cpp
- src/ITileOperand.cpp
- src/Kernel.cpp
- src/KernelWriter.cpp
+ src/TileOperand.cpp
)
if(CKW_ENABLE_OPENCL)