aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorViet-Hoa Do <viet-hoa.do@arm.com>2023-07-05 17:36:40 +0100
committerViet-Hoa Do <viet-hoa.do@arm.com>2023-07-11 13:46:38 +0000
commit3389f530fb19247889048f9a2b2eedda14f3fea2 (patch)
tree5e22f5f014194f6382a35b2c7eae4e805d2541bf /compute_kernel_writer/CMakeLists.txt
parent8e2dedea8550b1c18c3bbeead8c972f661dcfac8 (diff)
downloadComputeLibrary-3389f530fb19247889048f9a2b2eedda14f3fea2.tar.gz
Add kernel and kernel writer skeletons
* Add the skeleton for kernel, kernel writer and their respective OpenCL implementation. * Add method to write code comment and its test. Resolves: COMPMID-6343 Signed-off-by: Viet-Hoa Do <viet-hoa.do@arm.com> Change-Id: Ib986228154f7a00da7a5fd3b7105941325fe13b1 Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9889 Tested-by: Arm Jenkins <bsgcomp@arm.com> Reviewed-by: Gunes Bayir <gunes.bayir@arm.com> Comments-Addressed: Arm Jenkins <bsgcomp@arm.com> Benchmark: Arm Jenkins <bsgcomp@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index 3bc2aeda63..d763bc6de5 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -124,6 +124,8 @@ target_sources(ckw PRIVATE
src/TensorUtils.cpp
src/TileInfo.cpp
src/ITileOperand.cpp
+ src/Kernel.cpp
+ src/KernelWriter.cpp
)
if(CKW_ENABLE_OPENCL)
@@ -132,6 +134,7 @@ if(CKW_ENABLE_OPENCL)
src/cl/CLHelpers.cpp
src/cl/CLTile.cpp
src/cl/ICLTile.cpp
+ src/cl/CLKernelWriter.cpp
)
endif()
@@ -145,9 +148,6 @@ target_include_directories(ckw
if(CKW_BUILD_TESTING)
add_executable(ckw_validation
- validation/tests/common/Common.h
- validation/tests/TensorBitMaskTest.hpp
- validation/tests/UtilsTest.hpp
validation/Validation.cpp
)
if(CKW_ENABLE_OPENCL)