aboutsummaryrefslogtreecommitdiff
path: root/thirdparty/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Kunze <eric.kunze@arm.com>2022-06-22 11:30:23 -0700
committerEric Kunze <eric.kunze@arm.com>2022-08-22 22:59:54 +0000
commit286f834ce60e4ebcaaf131cb7da97ebf79098fa0 (patch)
tree83baf6a241912f980a0b1b311726fb5f7c97ac1e /thirdparty/CMakeLists.txt
parent3c59d5d2b4c20ec64daff76fd04a374c5a5055e0 (diff)
downloadreference_model-286f834ce60e4ebcaaf131cb7da97ebf79098fa0.tar.gz
Simplify the argument parsing and debug code
Change-Id: Ia681aa0eb1d42fa31a4658badb376f7b32b2e338 Signed-off-by: Eric Kunze <eric.kunze@arm.com>
Diffstat (limited to 'thirdparty/CMakeLists.txt')
-rw-r--r--thirdparty/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
index a85af3c..abcc52c 100644
--- a/thirdparty/CMakeLists.txt
+++ b/thirdparty/CMakeLists.txt
@@ -1,8 +1,17 @@
cmake_minimum_required (VERSION 3.4)
+# fetch 3rd party libraries
+include(FetchContent)
+FetchContent_Declare(
+ cxxopts
+ URL https://github.com/jarro2783/cxxopts/archive/v2.2.1.tar.gz
+ URL_MD5 6e70da4fc17a09f32612443f1866042e
+)
+
set(CMAKE_INSTALL_PREFIX "./thirdparty" CACHE PATH "..." FORCE)
project(thirdparty LANGUAGES CXX)
+add_subdirectory(cxxopts)
add_subdirectory(serialization_lib EXCLUDE_FROM_ALL)
add_subdirectory(json EXCLUDE_FROM_ALL)