summaryrefslogtreecommitdiff
path: root/source/profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/profiler/CMakeLists.txt')
-rw-r--r--source/profiler/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/source/profiler/CMakeLists.txt b/source/profiler/CMakeLists.txt
index f70e86d..e59dc01 100644
--- a/source/profiler/CMakeLists.txt
+++ b/source/profiler/CMakeLists.txt
@@ -34,6 +34,10 @@ target_include_directories(profiler PUBLIC include)
# Profiling API depends on the logging interface and the HAL library.
target_link_libraries(profiler PRIVATE log hal)
+# Set the CPU profiling defintiion
+target_compile_definitions(profiler PUBLIC
+ $<$<BOOL:${CPU_PROFILE_ENABLED}>:CPU_PROFILE_ENABLED>)
+
message(STATUS "*******************************************************")
message(STATUS "Library : " profiler)
message(STATUS "CMAKE_SYSTEM_PROCESSOR : " ${CMAKE_SYSTEM_PROCESSOR})