summaryrefslogtreecommitdiff
path: root/source/hal/cmsis_device/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-02-24 09:51:02 +0000
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-02-25 16:26:41 +0000
commitfb93fa74b821d883e7d19999dfd1a358aacebb88 (patch)
treed8ba4f417153fa645418641c114e6958dccfbdf8 /source/hal/cmsis_device/CMakeLists.txt
parent0ab250b4b5dfae3f7b3cae5d5f5d4295126c0967 (diff)
downloadml-embedded-evaluation-kit-fb93fa74b821d883e7d19999dfd1a358aacebb88.tar.gz
MLECO-2944: CMSIS device refactoring
* RTE_components header to include corresponding Arm Cortex-M system header * remove custom CMSIS implementation from repo * use templates within CMSIS repo instead * update cmake to use header and source files within CMSIS repo Change-Id: I3534dae97b93c07a5056471b1d1dedbc78f00aa7
Diffstat (limited to 'source/hal/cmsis_device/CMakeLists.txt')
-rw-r--r--source/hal/cmsis_device/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/source/hal/cmsis_device/CMakeLists.txt b/source/hal/cmsis_device/CMakeLists.txt
index 9f834d5..255bd30 100644
--- a/source/hal/cmsis_device/CMakeLists.txt
+++ b/source/hal/cmsis_device/CMakeLists.txt
@@ -50,8 +50,12 @@ target_include_directories(${CMSIS_DEVICE_TARGET}
## Sources
target_sources(${CMSIS_DEVICE_TARGET}
PRIVATE
- source/cmsis.c
- source/irqs.c)
+ ${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Source/system_${ARM_CPU}.c
+ ${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Source/startup_${ARM_CPU}.c)
+
+# Device definition needs to be set, is checked in source files to include correct header
+target_compile_definitions(${CMSIS_DEVICE_TARGET} PUBLIC ${ARM_CPU})
+
# Tell linker that reset interrupt handler is our entry point
target_link_options(