summaryrefslogtreecommitdiff
path: root/source/hal/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-03-03 16:30:07 +0000
committerIsabella Gottardi <isabella.gottardi@arm.com>2022-03-04 11:09:15 +0000
commitd5679cc8db0a6ab43369eb91089ea5fe015f552f (patch)
tree4477b3f1e5b5a70066d958d98e61ba6e5a183bb5 /source/hal/CMakeLists.txt
parentb4123fd715e41070be5bb39600625c740185f562 (diff)
downloadml-embedded-evaluation-kit-d5679cc8db0a6ab43369eb91089ea5fe015f552f.tar.gz
MLECO-2984: Refactor components
* Use UART component from Ethos-U core-platform * Components as cmake project Change-Id: I053f3a59800abc20216e6a4df8555db357e3f21d Signed-off-by: Isabella Gottardi <isabella.gottardi@arm.com>
Diffstat (limited to 'source/hal/CMakeLists.txt')
-rw-r--r--source/hal/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/hal/CMakeLists.txt b/source/hal/CMakeLists.txt
index 536682f..f720cdf 100644
--- a/source/hal/CMakeLists.txt
+++ b/source/hal/CMakeLists.txt
@@ -108,16 +108,18 @@ elseif (PLATFORM_PROFILE STREQUAL native)
PUBLIC
PLATFORM_HAL=PLATFORM_UNKNOWN_LINUX_OS
ACTIVATION_BUF_SRAM_SZ=0)
+else()
+ message(FATAL_ERROR "PLATFORM_PROFILE ${PLATFORM_PROFILE} not supported")
endif()
-# Add platform-drivers target
+# Add platform_drivers target
add_subdirectory(${PLATFORM_DRIVERS_DIR} ${CMAKE_BINARY_DIR}/platform_driver)
# Link time library targets:
target_link_libraries(${HAL_TARGET}
PUBLIC
log
- platform-drivers)
+ platform_drivers)
# Display status:
message(STATUS "CMAKE_CURRENT_SOURCE_DIR: " ${CMAKE_CURRENT_SOURCE_DIR})