summaryrefslogtreecommitdiff
path: root/source/hal/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-04-01 14:43:53 +0100
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-04-05 09:30:23 +0100
commitda2ec067da418d3d80b2829b111df25bd901eb5c (patch)
tree0ccba5c7655ad042bd21f71ffd59c0f52c163f62 /source/hal/CMakeLists.txt
parent8bc863dd6a7d0937aa66df655a7fe0e235dd2d4f (diff)
downloadml-embedded-evaluation-kit-da2ec067da418d3d80b2829b111df25bd901eb5c.tar.gz
MLECO-3096: Removing "timer" from HAL profile.
Attempting to have timer functionality contained within the platform drivers "package" as it should (in line with the refactoring work done so far under HAL). This will ensure that we don't need two timer implementations under HAL "profiles" and therefore, this whole directory can be removed. This change also addressed issue with the applicatio level Profiler code knowing about how the PMU has been set up by the platform code. This link has been removed completely. This will make it much easier to add/amend the Ethos-U PMU event counters types and give each platform the capability of populating their relvant counters. The application level Profiler doesn't know which metrics it is displaying but just calculates and maintains statistics for whatever PMU counters it receives from the HAL level. A fix for timing adapter issue introduced in the last CR is also included. Change-Id: Ia46e03a06e7b8e42b9ed2ba8f2af2dcd2229c110 Signed-off-by: Kshitij Sisodia <kshitij.sisodia@arm.com>
Diffstat (limited to 'source/hal/CMakeLists.txt')
-rw-r--r--source/hal/CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/source/hal/CMakeLists.txt b/source/hal/CMakeLists.txt
index 19f152c..10016c2 100644
--- a/source/hal/CMakeLists.txt
+++ b/source/hal/CMakeLists.txt
@@ -30,20 +30,10 @@ project(${HAL_TARGET}
# Create static library
add_library(${HAL_TARGET} STATIC)
-# Select which profile needs to be used:
-if (${CMAKE_CROSSCOMPILING})
- set(PLATFORM_PROFILE bare-metal)
-else()
- set(PLATFORM_PROFILE native)
-endif()
-
-set(PLATFORM_PROFILE_DIR source/profiles/${PLATFORM_PROFILE})
-
## Common include directories - public
target_include_directories(${HAL_TARGET}
PUBLIC
- include
- ${PLATFORM_PROFILE_DIR}/timer/include)
+ include)
## Common sources for all profiles
target_sources(${HAL_TARGET}
@@ -51,7 +41,7 @@ target_sources(${HAL_TARGET}
source/hal.c
source/data_psn.c
source/data_acq.c
- ${PLATFORM_PROFILE_DIR}/timer/platform_timer.c)
+ source/hal_timer.c)
if (DEFINED VERIFY_TEST_OUTPUT)
message(STATUS "Test output verification flag is: ${VERIFY_TEST_OUTPUT}")