aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 57cc2aee..805062b0 100644
--- a/setup.py
+++ b/setup.py
@@ -44,6 +44,12 @@ mlw_module = Extension(
["ethosu/mlw_codec/mlw_encode.c", "ethosu/mlw_codec/mlw_decode.c", "ethosu/mlw_codec/mlw_codecmodule.c"],
)
+tensor_allocator_module = Extension(
+ "ethosu.tensor_allocator",
+ ["ethosu/tensor_allocator/tensor_allocatormodule.cpp", "ethosu/tensor_allocator/search_allocator.cpp"],
+ depends=["ethosu/tensor_allocator/search_allocator.h"],
+)
+
setup(
name="ethos-u-vela",
use_scm_version=True,
@@ -59,6 +65,7 @@ setup(
"License :: OSI Approved :: Apache Software License",
"Operating System :: POSIX :: Linux",
"Programming Language :: C",
+ "Programming Language :: C++ :: C++11",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
@@ -71,6 +78,6 @@ setup(
python_requires="~=3.6", # We support only 3.6+
install_requires=["flatbuffers==1.11.0", "numpy>=1.16.6", "lxml>=4.5.1"],
entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
- ext_modules=[mlw_module],
+ ext_modules=[mlw_module, tensor_allocator_module],
setup_requires=["setuptools_scm"],
)