aboutsummaryrefslogtreecommitdiff
path: root/utils/inference_runner/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/inference_runner/CMakeLists.txt')
-rw-r--r--utils/inference_runner/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/utils/inference_runner/CMakeLists.txt b/utils/inference_runner/CMakeLists.txt
new file mode 100644
index 0000000..66a0612
--- /dev/null
+++ b/utils/inference_runner/CMakeLists.txt
@@ -0,0 +1,32 @@
+#
+# Copyright (c) 2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.0.2)
+
+# Set the project name and version
+project("inference_runner" VERSION 1.0)
+
+# Build executable
+add_executable(inference_runner "inference_runner.cpp")
+
+# Link agains ethosu library
+target_link_libraries(inference_runner ethosu)
+set(CMAKE_EXE_LINKER_FLAGS "-static")
+
+# Install target
+install(TARGETS inference_runner DESTINATION "bin")