aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..37b7d8b
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,37 @@
+#
+# Copyright (c) 2022 Arm Limited.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+set(CORE_PLATFORM_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../core_platform)
+
+file(GLOB models LIST_DIRECTORIES true "${CORE_PLATFORM_PATH}/applications/baremetal/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+
+# Build executable
+foreach(model ${models})
+ get_filename_component(modelname ${model} NAME)
+
+ add_executable(lds_${modelname}_tests "main.cpp")
+
+ target_include_directories(lds_${modelname}_tests PRIVATE
+ ${model})
+
+ # Link agains ethosu library
+ target_link_libraries(lds_${modelname}_tests PRIVATE ethosu)
+
+ # Install target
+ install(TARGETS lds_${modelname}_tests DESTINATION "bin")
+endforeach()