aboutsummaryrefslogtreecommitdiff
path: root/remoteproc/CMakeLists.txt
diff options
context:
space:
mode:
authorPer Åstrand <per.astrand@arm.com>2021-04-12 13:46:04 +0200
committerPer Åstrand <per.astrand@arm.com>2021-06-21 11:31:29 +0200
commit2cd539705ba4b510859f18e9815a72950ddd96fa (patch)
treedebfabdd521b93566fa3612e27a412a350b97208 /remoteproc/CMakeLists.txt
parent87ca5dac68ffd40007e31e11b32980a6d5b7cf83 (diff)
downloadethos-u-linux-driver-stack-2cd539705ba4b510859f18e9815a72950ddd96fa.tar.gz
Use remoteproc for controlling Ethos-U cpu
Implement a remoteproc driver for controlling firmware loading and powering up and down of the CPU on a Ethos-U subsystem. Change-Id: I075d24c780b306aa8152c4a9e24a31df29574f9e
Diffstat (limited to 'remoteproc/CMakeLists.txt')
-rw-r--r--remoteproc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/remoteproc/CMakeLists.txt b/remoteproc/CMakeLists.txt
index 9c88df1..1532f6c 100644
--- a/remoteproc/CMakeLists.txt
+++ b/remoteproc/CMakeLists.txt
@@ -40,7 +40,7 @@ list(TRANSFORM OBJ PREPEND ${CMAKE_CURRENT_SOURCE_DIR}/)
add_custom_target(ethosu-remoteproc-module ALL
COMMAND ${CMAKE_MAKE_PROGRAM} -C ${KDIR}
EXTRA_CFLAGS=-I${KDIR}/../../../drivers/remoteproc M=${CMAKE_CURRENT_SOURCE_DIR}
- CONFIG_ETHOSU_RESET=m
+ CONFIG_ETHOSU_RESET=m CONFIG_ETHOSU_REMOTEPROC=m
CROSS_COMPILE=aarch64-linux-gnu- ARCH=arm64 modules
BYPRODUCTS
${CMAKE_CURRENT_SOURCE_DIR}/ethosu_remoteproc.ko