aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2020-09-10 13:26:01 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2020-09-17 13:23:27 +0200
commitb74492c5aee3786b886951e87f4e5ea8d6032733 (patch)
tree76ef44dfdb68d68964877b0adba21cbce2416fe5 /CMakeLists.txt
parent116a635581f292cb4882ea1a086f842904f85c3c (diff)
downloadethos-u-linux-driver-stack-b74492c5aee3786b886951e87f4e5ea8d6032733.tar.gz
Support inferences with multiple inputs and outputs
Build flatbuffers library. Update network class to extract IFM and OFM dimensions from the tflite file. Update the uapi and core apis to support up to 16 IFM and OFM buffers per inference. Change-Id: I2f2f177aa4c2d5f9f50f23eb33c44e01ec2cbe09
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51f6195..fc2b91f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,5 +40,18 @@ if (BUILD_MAILBOX)
add_subdirectory(mailbox)
endif()
+# Build flatbuffers
+unset(PROJECT_VERSION)
+unset(PROJECT_VERSION_MAJOR)
+unset(PROJECT_VERSION_MINOR)
+option(FLATBUFFERS_BUILD_TESTS OFF)
+option(FLATBUFFERS_INSTALL OFF)
+option(FLATBUFFERS_BUILD_FLATC OFF)
+option(FLATBUFFERS_BUILD_FLATHASH OFF)
+add_subdirectory(flatbuffers)
+
+# Build driver library
add_subdirectory(driver_library)
+
+# Build utils
add_subdirectory(utils)