aboutsummaryrefslogtreecommitdiff
path: root/lib/ethosu_profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ethosu_profiler/CMakeLists.txt')
-rw-r--r--lib/ethosu_profiler/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/ethosu_profiler/CMakeLists.txt b/lib/ethosu_profiler/CMakeLists.txt
new file mode 100644
index 0000000..85ef7d9
--- /dev/null
+++ b/lib/ethosu_profiler/CMakeLists.txt
@@ -0,0 +1,21 @@
+#
+# SPDX-FileCopyrightText: Copyright 2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_profiler STATIC)
+
+target_include_directories(ethosu_profiler PUBLIC include)
+target_sources(ethosu_profiler PRIVATE src/ethosu_profiler.cpp)