aboutsummaryrefslogtreecommitdiff
path: root/drivers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/CMakeLists.txt')
-rw-r--r--drivers/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/drivers/CMakeLists.txt b/drivers/CMakeLists.txt
deleted file mode 100644
index 10b97cb..0000000
--- a/drivers/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (c) 2020-2021 Arm Limited. All rights reserved.
-#
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the License); you may
-# not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an AS IS BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-add_library(ethosu_drivers INTERFACE)
-
-#############################################################################
-# Mailbox driver
-#############################################################################
-add_subdirectory(mailbox)
-target_link_libraries(ethosu_drivers INTERFACE ethosu_mailbox)
-
-#############################################################################
-# MHU drivers
-#############################################################################
-# NOTE: These are all built and linked from a CMake perspective. However the
-# application code can instantiate one or more of the drivers. The
-# one(s) not used will later be removed by the linker.
-add_subdirectory(mhu_v2)
-add_subdirectory(mhu_juno)
-add_subdirectory(mhu_dummy)
-target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_v2)
-target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_juno)
-target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_dummy)
-
-#############################################################################
-# UART drivers
-#############################################################################
-# NOTE: All UART drivers are built, however a platform application should
-# link the appropriate driver target (see drivers/uart/CMakeLists.txt).
-add_subdirectory(uart)
-
-#############################################################################
-# Timing adapter driver
-#############################################################################
-add_subdirectory(timing_adapter)
-target_link_libraries(ethosu_drivers INTERFACE timing_adapter)