aboutsummaryrefslogtreecommitdiff
path: root/applications/message_process/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/message_process/CMakeLists.txt')
-rw-r--r--applications/message_process/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/applications/message_process/CMakeLists.txt b/applications/message_process/CMakeLists.txt
index 7390ed7..1e31d68 100644
--- a/applications/message_process/CMakeLists.txt
+++ b/applications/message_process/CMakeLists.txt
@@ -18,4 +18,8 @@
add_library(message_process STATIC src/message_process.cpp)
target_include_directories(message_process PUBLIC include ${LINUX_DRIVER_STACK_PATH}/kernel)
+
target_link_libraries(message_process PRIVATE cmsis_device inference_process ethosu_mailbox)
+if (CORE_SOFTWARE_ACCELERATOR STREQUAL "NPU")
+ target_link_libraries(message_process PRIVATE ethosu_core_driver)
+endif()