aboutsummaryrefslogtreecommitdiff
path: root/rtos/CMakeLists.txt
diff options
context:
space:
mode:
authorBhavik Patel <bhavik.patel@arm.com>2020-07-29 12:28:18 +0200
committerBhavik Patel <bhavik.patel@arm.com>2020-10-27 16:58:48 +0100
commit68c1f1b463691fadbccef22e22d59f5e61546ca2 (patch)
tree1753440d0eada82577720109b92ada22ca3831f0 /rtos/CMakeLists.txt
parentd273d8e9c8513079f807b48af2e277f46469acf0 (diff)
downloadethos-u-core-software-68c1f1b463691fadbccef22e22d59f5e61546ca2.tar.gz
MLBEDSW-2593 Build FreeRTOS kernel as a part of ethosu_core target
The ethosu_core target now includes the FreeRTOS kernel if the CORE_SOFTWARE_RTOS is set to FreeRTOS. Currently supported builds are for cortex M3, M4, M7, M33, and M55. The FreeRTOSConfig.h file is generated as a part of the build. Change-Id: Ief6921fd0d9aa3849497ef0810d2714a12eb6773
Diffstat (limited to 'rtos/CMakeLists.txt')
-rw-r--r--rtos/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/rtos/CMakeLists.txt b/rtos/CMakeLists.txt
new file mode 100644
index 0000000..7c15d9e
--- /dev/null
+++ b/rtos/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright (c) 2019-2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_core_rtos INTERFACE)
+
+# Include FreeRTOS kernel & link with ethosu_rtos target
+if(CORE_SOFTWARE_RTOS_LOWER STREQUAL "freertos")
+ set(FREERTOS_KERNEL_PATH "${CMAKE_CURRENT_SOURCE_DIR}/freertos/freertos_kernel" CACHE PATH "Path to FreeRTOS kernel.")
+ add_subdirectory(freertos_config)
+ target_link_libraries(ethosu_core_rtos INTERFACE freertos_kernel)
+endif()