aboutsummaryrefslogtreecommitdiff
path: root/lib/ethosu_profiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMikael Olsson <mikael.olsson@arm.com>2023-12-11 17:24:49 +0100
committerMikael Olsson <mikael.olsson@arm.com>2023-12-15 14:09:43 +0100
commit578af8fd1f88cc50ee44498ddd3b879eba686c86 (patch)
treea9c5edd2bfb09114d672dfdf8eddb261458ab70d /lib/ethosu_profiler/CMakeLists.txt
parentd9afc0ab30060517f5a18efc7c70f412d0d99340 (diff)
downloadethos-u-core-software-578af8fd1f88cc50ee44498ddd3b879eba686c86.tar.gz
Add NPU placeholder profiler lib24.02-rc124.02
A placeholder profiler lib has been added with weak functions that can be implemented to add further profiling functionality. Change-Id: I111d0188c8e7d2b55106e8a93ca4a048faddb263 Signed-off-by: Mikael Olsson <mikael.olsson@arm.com>
Diffstat (limited to 'lib/ethosu_profiler/CMakeLists.txt')
-rw-r--r--lib/ethosu_profiler/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/ethosu_profiler/CMakeLists.txt b/lib/ethosu_profiler/CMakeLists.txt
new file mode 100644
index 0000000..85ef7d9
--- /dev/null
+++ b/lib/ethosu_profiler/CMakeLists.txt
@@ -0,0 +1,21 @@
+#
+# SPDX-FileCopyrightText: Copyright 2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_profiler STATIC)
+
+target_include_directories(ethosu_profiler PUBLIC include)
+target_sources(ethosu_profiler PRIVATE src/ethosu_profiler.cpp)