aboutsummaryrefslogtreecommitdiff
path: root/lib/ethosu_monitor/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Elofsson <jens.elofsson@arm.com>2021-05-18 11:30:35 +0200
committerFredrik Knutsson <fredrik.knutsson@arm.com>2021-05-27 11:26:13 +0000
commita9817a1b10f130c284e9283f5e6893d1f271e2a3 (patch)
tree2d8ebe4319507e5a13bf97fb437694ebc12402e6 /lib/ethosu_monitor/CMakeLists.txt
parent44d6e22f953839a9e294a36d975289eac8615cf2 (diff)
downloadethos-u-core-software-a9817a1b10f130c284e9283f5e6893d1f271e2a3.tar.gz
Add ethosu_monitor to core_software.21.05-rc3
Change-Id: I9423c0c2a8aca738b2788ff5c41e946432188dc3
Diffstat (limited to 'lib/ethosu_monitor/CMakeLists.txt')
-rw-r--r--lib/ethosu_monitor/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/ethosu_monitor/CMakeLists.txt b/lib/ethosu_monitor/CMakeLists.txt
new file mode 100644
index 0000000..50f6526
--- /dev/null
+++ b/lib/ethosu_monitor/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+if (NOT TARGET ethosu_core_driver)
+ return()
+endif()
+add_library(ethosu_monitor INTERFACE)
+
+target_link_libraries(ethosu_monitor INTERFACE ethosu_core_driver event_recorder)
+target_include_directories(ethosu_monitor INTERFACE include)
+target_sources(ethosu_monitor INTERFACE src/ethosu_monitor.cpp)