aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Elofsson <jens.elofsson@arm.com>2021-04-22 20:57:15 +0200
committerMåns Nilsson <mans.nilsson@arm.com>2021-05-21 09:59:19 +0200
commit955288a1b08bbfb0ea5fc0c5994b1a3a6ff8506e (patch)
tree53f09fef19895b80012b95633106e1e823b64ad7 /lib/CMakeLists.txt
parent7f3c1c92732b611a53968b14e70a2b116e43b980 (diff)
downloadethos-u-core-software-955288a1b08bbfb0ea5fc0c5994b1a3a6ff8506e.tar.gz
Add EthosuProfiler to perform layer-by-layer profiling on Ethos-U.
Change-Id: Idae34fd8ab6b17b0bc21db658fff135a5ddf5461
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000..abf444f
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# Build ethosu_profiler
+add_subdirectory(ethosu_profiler)
+
+# Build arm_profiler
+add_subdirectory(arm_profiler)