aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMikael Olsson <mikael.olsson@arm.com>2023-12-11 17:24:49 +0100
committerMikael Olsson <mikael.olsson@arm.com>2023-12-15 14:09:43 +0100
commit578af8fd1f88cc50ee44498ddd3b879eba686c86 (patch)
treea9c5edd2bfb09114d672dfdf8eddb261458ab70d /lib/CMakeLists.txt
parentd9afc0ab30060517f5a18efc7c70f412d0d99340 (diff)
downloadethos-u-core-software-578af8fd1f88cc50ee44498ddd3b879eba686c86.tar.gz
Add NPU placeholder profiler lib24.02-rc124.02
A placeholder profiler lib has been added with weak functions that can be implemented to add further profiling functionality. Change-Id: I111d0188c8e7d2b55106e8a93ca4a048faddb263 Signed-off-by: Mikael Olsson <mikael.olsson@arm.com>
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 06e660b..ed7aad1 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -1,6 +1,5 @@
#
-# Copyright (c) 2021-2022 Arm Limited. All rights reserved.
-#
+# SPDX-FileCopyrightText: Copyright 2021-2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
# SPDX-License-Identifier: Apache-2.0
#
# Licensed under the Apache License, Version 2.0 (the License); you may
@@ -28,5 +27,8 @@ add_subdirectory(ethosu_monitor)
# Build ethosu_logging
add_subdirectory(ethosu_log)
+# Build ethosu_profiler
+add_subdirectory(ethosu_profiler)
+
# Build crc lib
add_subdirectory(crc)