aboutsummaryrefslogtreecommitdiff
path: root/drivers/uart/CMakeLists.txt
diff options
context:
space:
mode:
authorYulia Garbovich <yulia.garbovich@arm.com>2021-11-23 20:10:26 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2021-12-14 15:42:02 +0000
commit05244b78be9eba0c83f6267fdbb3aa34e60eec98 (patch)
treec86a7374318814d10636f9ed30105fb55bf2b138 /drivers/uart/CMakeLists.txt
parentae4d83089982e9d9fb11e7152bf9442b220d8b01 (diff)
downloadethos-u-core-software-05244b78be9eba0c83f6267fdbb3aa34e60eec98.tar.gz
Move drivers to core_platform
Move to core_platform repository. core_software repository should only contain components related to running an inference. Drivers are platform components. Change-Id: I232ef14ce151db7e89cef39ec3b2d6c0b4da8aef
Diffstat (limited to 'drivers/uart/CMakeLists.txt')
-rw-r--r--drivers/uart/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/drivers/uart/CMakeLists.txt b/drivers/uart/CMakeLists.txt
deleted file mode 100644
index 1293bdc..0000000
--- a/drivers/uart/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (c) 2019-2020 Arm Limited. All rights reserved.
-#
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the License); you may
-# not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an AS IS BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-add_library(ethosu_uart_common INTERFACE)
-
-target_include_directories(ethosu_uart_common INTERFACE
- include
- ${CMAKE_CURRENT_BINARY_DIR})
-
-# UART configuration (can be overriden from user project)
-set(UART0_BASE "0xFFFFFFFF" CACHE STRING "UART base address")
-set(UART0_BAUDRATE "115200" CACHE STRING "UART baudrate")
-set(SYSTEM_CORE_CLOCK "25000000" CACHE STRING "System core clock (Hz)")
-
-# Generate UART configuration file
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/uart_config.h.in" "${CMAKE_CURRENT_BINARY_DIR}/uart_config.h")
-
-# Drivers
-add_library(ethosu_uart_cmsdk_apb STATIC src/uart_cmsdk_apb.c)
-target_link_libraries(ethosu_uart_cmsdk_apb PUBLIC ethosu_uart_common)
-
-add_library(ethosu_uart_pl011 STATIC src/uart_pl011.c)
-target_link_libraries(ethosu_uart_pl011 PUBLIC ethosu_uart_common)
-
-add_library(ethosu_uart_dummy STATIC src/uart_dummy.c)
-target_link_libraries(ethosu_uart_dummy PUBLIC ethosu_uart_common)