aboutsummaryrefslogtreecommitdiff
path: root/drivers/CMakeLists.txt
diff options
context:
space:
mode:
authorJonny Svärd <jonny.svaerd@arm.com>2020-12-15 16:02:41 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2020-12-17 12:30:53 +0000
commitff265f9ad6505878a1b55d560ee697531fa33044 (patch)
tree4bdacd81701f3045c0a253525d756045a23607ef /drivers/CMakeLists.txt
parent7cfa570a4a25d8ab2a05c856a8b1bfa0855b9bee (diff)
downloadethos-u-core-software-ff265f9ad6505878a1b55d560ee697531fa33044.tar.gz
Add basic UART drivers
Add basic drivers for: - PL011 UART - CMSDK APB UART - dummy/stub UART Change-Id: I2f89874fba59044e6c7c084f8e1dc6faa9eb8d1b
Diffstat (limited to 'drivers/CMakeLists.txt')
-rw-r--r--drivers/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/CMakeLists.txt b/drivers/CMakeLists.txt
index c130a26..9feeeae 100644
--- a/drivers/CMakeLists.txt
+++ b/drivers/CMakeLists.txt
@@ -18,11 +18,18 @@
add_library(ethosu_drivers INTERFACE)
+#############################################################################
# Mailbox driver
+#############################################################################
add_subdirectory(mailbox)
target_link_libraries(ethosu_drivers INTERFACE ethosu_mailbox)
+#############################################################################
# MHU drivers
+#############################################################################
+# NOTE: These are all built and linked from a CMake perspective. However the
+# application code can instantiate one or more of the drivers. The
+# one(s) not used will later be removed by the linker.
add_subdirectory(mhu_v2)
add_subdirectory(mhu_juno)
add_subdirectory(mhu_dummy)
@@ -30,3 +37,9 @@ target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_v2)
target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_juno)
target_link_libraries(ethosu_drivers INTERFACE ethosu_mhu_dummy)
+#############################################################################
+# UART drivers
+#############################################################################
+# NOTE: All UART drivers are built, however a platform application should
+# link the appropriate driver target (see drivers/uart/CMakeLists.txt).
+add_subdirectory(uart)