aboutsummaryrefslogtreecommitdiff
path: root/applications/message_process/CMakeLists.txt
diff options
context:
space:
mode:
authorDavide Grohmann <davide.grohmann@arm.com>2021-06-01 14:21:42 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2021-06-10 14:59:06 +0000
commit53cc13d7f685bb7bb89dc33e6f6b1dd64c5ac2f4 (patch)
treee986086a5476784f355db46c5c6bba4b336a793d /applications/message_process/CMakeLists.txt
parent5d6d4747baadccf532ed220bd5c4e3bb63c80bc1 (diff)
downloadethos-u-core-software-53cc13d7f685bb7bb89dc33e6f6b1dd64c5ac2f4.tar.gz
Add support for fetching ethosu capabilities
Change-Id: I5507b42a66649ab04f7a5932777830d105b3123b
Diffstat (limited to 'applications/message_process/CMakeLists.txt')
-rw-r--r--applications/message_process/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/applications/message_process/CMakeLists.txt b/applications/message_process/CMakeLists.txt
index 7390ed7..1e31d68 100644
--- a/applications/message_process/CMakeLists.txt
+++ b/applications/message_process/CMakeLists.txt
@@ -18,4 +18,8 @@
add_library(message_process STATIC src/message_process.cpp)
target_include_directories(message_process PUBLIC include ${LINUX_DRIVER_STACK_PATH}/kernel)
+
target_link_libraries(message_process PRIVATE cmsis_device inference_process ethosu_mailbox)
+if (CORE_SOFTWARE_ACCELERATOR STREQUAL "NPU")
+ target_link_libraries(message_process PRIVATE ethosu_core_driver)
+endif()