aboutsummaryrefslogtreecommitdiff
path: root/applications/inference_process/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Elofsson <jens.elofsson@arm.com>2021-04-22 20:57:15 +0200
committerMåns Nilsson <mans.nilsson@arm.com>2021-05-21 09:59:19 +0200
commit955288a1b08bbfb0ea5fc0c5994b1a3a6ff8506e (patch)
tree53f09fef19895b80012b95633106e1e823b64ad7 /applications/inference_process/CMakeLists.txt
parent7f3c1c92732b611a53968b14e70a2b116e43b980 (diff)
downloadethos-u-core-software-955288a1b08bbfb0ea5fc0c5994b1a3a6ff8506e.tar.gz
Add EthosuProfiler to perform layer-by-layer profiling on Ethos-U.
Change-Id: Idae34fd8ab6b17b0bc21db658fff135a5ddf5461
Diffstat (limited to 'applications/inference_process/CMakeLists.txt')
-rw-r--r--applications/inference_process/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/applications/inference_process/CMakeLists.txt b/applications/inference_process/CMakeLists.txt
index 67caae8..4bd75c4 100644
--- a/applications/inference_process/CMakeLists.txt
+++ b/applications/inference_process/CMakeLists.txt
@@ -22,5 +22,13 @@ add_library(inference_process STATIC)
target_include_directories(inference_process PUBLIC include
PRIVATE ${TENSORFLOW_PATH} ${TENSORFLOW_PATH}/tensorflow/lite/micro/tools/make/downloads/flatbuffers/include)
+
target_link_libraries(inference_process PRIVATE tflu cmsis_core cmsis_device)
-target_sources(inference_process PRIVATE src/inference_process.cpp) \ No newline at end of file
+if (TARGET ethosu_profiler)
+ target_link_libraries(inference_process PRIVATE ethosu_profiler)
+endif()
+if (TARGET arm_profiler)
+ target_link_libraries(inference_process PRIVATE arm_profiler)
+endif()
+
+target_sources(inference_process PRIVATE src/inference_process.cpp)