aboutsummaryrefslogtreecommitdiff
path: root/applications/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2020-08-31 11:34:14 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2020-09-01 09:47:51 +0200
commit641c09157ebe25590e0ba378f70f05fc7466b8b1 (patch)
tree86d74b65c935e4485d32a6c94381a46b2d822f6a /applications/CMakeLists.txt
parent7e0775474aa06ecd264c5cec299f73e66c37af9e (diff)
downloadethos-u-core-software-641c09157ebe25590e0ba378f70f05fc7466b8b1.tar.gz
Moving message- and inference processes to core software20.08
Change-Id: I76e94440402d58848116d06ff3fd1ed2000ac505
Diffstat (limited to 'applications/CMakeLists.txt')
-rw-r--r--applications/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/applications/CMakeLists.txt b/applications/CMakeLists.txt
new file mode 100644
index 0000000..22de770
--- /dev/null
+++ b/applications/CMakeLists.txt
@@ -0,0 +1,27 @@
+#
+# Copyright (c) 2019-2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_applications INTERFACE)
+
+# Build message process
+add_subdirectory(message_process)
+target_link_libraries(ethosu_applications INTERFACE message_process)
+
+# Build inference process
+add_subdirectory(inference_process)
+target_link_libraries(ethosu_applications INTERFACE inference_process)