aboutsummaryrefslogtreecommitdiff
path: root/applications/message_handler/test/test_message_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/message_handler/test/test_message_handler/CMakeLists.txt')
-rw-r--r--applications/message_handler/test/test_message_handler/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/applications/message_handler/test/test_message_handler/CMakeLists.txt b/applications/message_handler/test/test_message_handler/CMakeLists.txt
new file mode 100644
index 0000000..bdccf54
--- /dev/null
+++ b/applications/message_handler/test/test_message_handler/CMakeLists.txt
@@ -0,0 +1,38 @@
+#
+# Copyright (c) 2020-2022 Arm Limited.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+if(NOT BUILD_TEST_MESSAGE_HANDLER OR NOT TARGET freertos_kernel)
+ message("Skipping test message handler")
+ return()
+endif()
+
+ethosu_add_executable(test_message_handler
+ SOURCES
+ main.cpp
+ LIBRARIES
+ message_handler_lib
+ freertos_kernel)
+
+target_include_directories(test_message_handler PRIVATE
+ ../../indexed_networks
+ ${LINUX_DRIVER_STACK_PATH}/kernel)
+
+install(FILES $<TARGET_FILE:test_message_handler>
+ DESTINATION "lib/firmware"
+ RENAME "arm-test-${ETHOSU_TARGET_NPU_CONFIG}.fw"
+)