aboutsummaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
new file mode 100644
index 0000000..e1242b3
--- /dev/null
+++ b/zephyr/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_policy(SET CMP0079 NEW)
+
+# Include Ethos-U core driver
+add_subdirectory(.. core_driver)
+
+# Append Zephyr build environment to core driver target
+
+target_link_libraries(ethosu_core_driver PUBLIC
+ zephyr_interface)
+
+# Add init files
+zephyr_sources(
+ init.c)