aboutsummaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authoravishi01 <avi.shif@arm.com>2021-11-08 16:24:55 +0000
committerKristofer Jonsson <kristofer.jonsson@arm.com>2021-11-30 10:39:09 +0000
commit2ceee3798df328f9221d7168ac046dfda10417f8 (patch)
tree09ba2eb25ba46522c7f8477eb56d2fb2e09d77f1 /zephyr/CMakeLists.txt
parent089a34786cbe02863eaa79f39dc92bf061dfcda8 (diff)
downloadethos-u-core-driver-2ceee3798df328f9221d7168ac046dfda10417f8.tar.gz
Support of tflu application using ethosu and Zephyr
move the zephyr basic files to zephyr/modules/ethos-u-core-driver and update the module name in module.yml to ethos-u-core-driver move relevant cmake configuration to the CMakeLists.txt (from the applications CMakeLists.txt). Change-Id: I5b801ed06ffcfeb618fdb375c0c81b59b8ee4b1e
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt31
1 files changed, 0 insertions, 31 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
deleted file mode 100644
index e1242b3..0000000
--- a/zephyr/CMakeLists.txt
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# Copyright (c) 2021 Arm Limited. All rights reserved.
-#
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the License); you may
-# not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an AS IS BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-cmake_policy(SET CMP0079 NEW)
-
-# Include Ethos-U core driver
-add_subdirectory(.. core_driver)
-
-# Append Zephyr build environment to core driver target
-
-target_link_libraries(ethosu_core_driver PUBLIC
- zephyr_interface)
-
-# Add init files
-zephyr_sources(
- init.c)