aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonny Svärd <jonny.svaerd@arm.com>2024-04-25 21:23:31 +0200
committerJonny Svärd <jonny.svaerd@arm.com>2024-05-07 10:20:03 +0000
commit9622608a5cc318c0933bcce720b59737d03bfb6f (patch)
tree4c08612af613cc52fd929736df3012329df0f252 /CMakeLists.txt
parent826638e203ededd31825dbf767130e3a17d4218c (diff)
downloadethos-u-core-driver-main.tar.gz
Add initial support for Ethos-U85HEAD24.05-rc1main
Change-Id: I28d7cb72c149a636a4f1d8ca6931316486b1829a Signed-off-by: Jonny Svärd <jonny.svaerd@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 350ac40..7fed522 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,5 @@
#
-# SPDX-FileCopyrightText: Copyright 2019-2021, 2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
-#
+# SPDX-FileCopyrightText: Copyright 2019-2021, 2023-2024 Arm Limited and/or its affiliates <open-source-office@arm.com>
# SPDX-License-Identifier: Apache-2.0
#
# Licensed under the Apache License, Version 2.0 (the License); you may
@@ -59,19 +58,21 @@ target_include_directories(ethosu_core_driver PUBLIC include)
target_sources(ethosu_core_driver PRIVATE src/ethosu_driver.c src/ethosu_pmu.c)
string(TOLOWER ${ETHOSU_TARGET_NPU_CONFIG} ETHOSU_TARGET_NPU_CONFIG)
-if(ETHOSU_TARGET_NPU_CONFIG MATCHES "^ethos-(u[0-9]+|uz)-([0-9]+$)")
+if(ETHOSU_TARGET_NPU_CONFIG MATCHES "^ethos-(u[0-9]+)-([0-9]+$)")
set(ETHOSU_ARCH ${CMAKE_MATCH_1})
set(ETHOSU_MACS ${CMAKE_MATCH_2})
else()
message(FATAL_ERROR "Invalid Ethos-U target configuration '${ETHOSU_TARGET_NPU_CONFIG}")
endif()
-target_compile_definitions(ethosu_core_driver PRIVATE
+target_compile_definitions(ethosu_core_driver PUBLIC
ETHOSU_ARCH=${ETHOSU_ARCH}
ETHOS$<UPPER_CASE:${ETHOSU_ARCH}>)
if (ETHOSU_ARCH STREQUAL "u55" OR ETHOSU_ARCH STREQUAL "u65")
target_sources(ethosu_core_driver PRIVATE src/ethosu_device_u55_u65.c)
+elseif (ETHOSU_ARCH STREQUAL "u85")
+ target_sources(ethosu_core_driver PRIVATE src/ethosu_device_u85.c)
else()
message(FATAL_ERROR "Invalid NPU configuration")
endif()
@@ -96,10 +97,7 @@ install(FILES include/ethosu_device.h include/ethosu_driver.h include/pmu_ethosu
# Define ETHOSU macro
target_compile_definitions(ethosu_core_driver PUBLIC ETHOSU)
-#
# Print build status
-#
-
message(STATUS "*******************************************************")
message(STATUS "PROJECT_NAME : ${PROJECT_NAME}")
message(STATUS "ETHOSU_TARGET_NPU_CONFIG : ${ETHOSU_TARGET_NPU_CONFIG}")