aboutsummaryrefslogtreecommitdiff
path: root/src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2021-10-26 21:26:10 +0100
committerJim Flynn <jim.flynn@arm.com>2021-10-26 21:27:22 +0100
commite1fdd2866b0f403b5e80994890d62c2c038c16c9 (patch)
treed7398443532cbafde7c6824015397e6bac6dd502 /src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt
parentca5883951ab51191eb19502459f0936fc96e14f1 (diff)
downloadarmnn-e1fdd2866b0f403b5e80994890d62c2c038c16c9.tar.gz
IVGCVSW-6470 Create MemoryStrategyBenchmark
* Refactor the strategy library to be more generic * Shorten the names of the current strategies * Change validatorStrat to throw exceptions Change-Id: I0d9c9ef609b2d8675e5788610d1accac6767c660 Signed-off-by: Finn Williams <finwil01@e127804.cambridge.arm.com> Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt')
-rw-r--r--src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt b/src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt
new file mode 100644
index 0000000000..43ec9db670
--- /dev/null
+++ b/src/backends/backendsCommon/memoryOptimizerStrategyLibrary/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright © 2021 Arm Ltd and Contributors. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+list(APPEND armnnMemoryOptimizationStrategies_sources
+ MemoryOptimizerStrategyLibrary.hpp
+ MemoryOptimizerStrategyFactory.hpp
+ strategies/ConstantMemoryStrategy.hpp
+ strategies/ConstantMemoryStrategy.cpp
+ strategies/StrategyValidator.hpp
+ strategies/StrategyValidator.cpp
+)
+
+if(BUILD_UNIT_TESTS)
+ add_subdirectory(test)
+endif()
+
+add_library(armnnMemoryOptimizationStrategies OBJECT ${armnnMemoryOptimizationStrategies_sources}) \ No newline at end of file