aboutsummaryrefslogtreecommitdiff
path: root/src/backends/backendsCommon/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-01-10 17:34:20 +0000
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-01-11 12:20:47 +0000
commit992d6dc57d8463729910b688f0fb5825d0d3ccf2 (patch)
tree87b504d174848169550240f300f359dd57aaa1fd /src/backends/backendsCommon/CMakeLists.txt
parent1f0ff35236c1dd05954735f7fed9c2807770479e (diff)
downloadarmnn-992d6dc57d8463729910b688f0fb5825d0d3ccf2.tar.gz
IVGCVSW-2454 Refactor ArmNN to support pluggable backends from a separate
code base * Made the virtual functions in ILayerSupport.hpp pure * Created a LayerSupportBase class with the default implementation of the interface * Made the backend layer support classes inherit from the base class, instead of directly from the interface * Refactored the profiler and the profiling event classes to use the BackendId instead of the Compute * Implemented a proper MemCopy support method * Changed Compute to BackendId in the profiling API and objects * Removed static references to pluggable backends !android-nn-driver:492 Change-Id: Id6332b5f48c980819e0a09adc818d1effd057296
Diffstat (limited to 'src/backends/backendsCommon/CMakeLists.txt')
-rw-r--r--src/backends/backendsCommon/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/backends/backendsCommon/CMakeLists.txt b/src/backends/backendsCommon/CMakeLists.txt
index b120f51184..1aa4d99dc3 100644
--- a/src/backends/backendsCommon/CMakeLists.txt
+++ b/src/backends/backendsCommon/CMakeLists.txt
@@ -11,7 +11,8 @@ list(APPEND armnnBackendsCommon_sources
CpuTensorHandle.hpp
IBackendInternal.hpp
IBackendContext.hpp
- ILayerSupport.cpp
+ LayerSupportBase.cpp
+ LayerSupportBase.hpp
IMemoryManager.hpp
ITensorHandle.hpp
MakeWorkloadHelper.hpp