aboutsummaryrefslogtreecommitdiff
path: root/src/armnnTfLiteParser/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2020-06-29 11:50:01 +0100
committerColm Donelan <colm.donelan@arm.com>2020-06-30 11:29:07 +0000
commit532a29d12d72f54549d8b71edd485c17af65698a (patch)
tree6748cc16706f52f413f7b2163a41d4807387cdf8 /src/armnnTfLiteParser/CMakeLists.txt
parent3b90af6bb79639d3813f21f3c3017503ee0c66af (diff)
downloadarmnn-532a29d12d72f54549d8b71edd485c17af65698a.tar.gz
IVGCVSW-4487 Remove boost::filesystem
* Replace filesystem::path * Replace filesystem::exists * Replace filesystem::is_directory * Replace filesystem::directory_iterator * Replace filesystem::filesystem_error exception * Replace filesystem::temp_directory_path * Replace filesystem::unique path * Replace filesystem::ofstream with std::ofstream * Replace filesystem::remove * Replace filesystem::is_regular_file * Replace boost::optional with armnn::Optional in touched files * Remove some superfluous includes * Update build guides, GlobalConfig.cmake and CMakeLists.txt * Remove redundant armnnUtils::Filesystem::Remove function. * Remove redundant armnnUtils::Filesystem::GetFileSize function. Temporarily adding back Boost::filesystem to enable Boost::dll. Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: Ifa46d4a0097d2612ddacd8e9736c0b36e365fb11
Diffstat (limited to 'src/armnnTfLiteParser/CMakeLists.txt')
-rwxr-xr-xsrc/armnnTfLiteParser/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/armnnTfLiteParser/CMakeLists.txt b/src/armnnTfLiteParser/CMakeLists.txt
index 97c55a1d08..d14cb75c49 100755
--- a/src/armnnTfLiteParser/CMakeLists.txt
+++ b/src/armnnTfLiteParser/CMakeLists.txt
@@ -18,7 +18,7 @@ if(BUILD_TF_LITE_PARSER)
target_include_directories(armnnTfLiteParser PRIVATE ../armnnUtils)
target_include_directories(armnnTfLiteParser SYSTEM PRIVATE "${TF_LITE_SCHEMA_INCLUDE_PATH}")
- target_link_libraries(armnnTfLiteParser ${Boost_FILESYSTEM_LIBRARY} ${Boost_THREAD_LIBRARY})
+ target_link_libraries(armnnTfLiteParser ${Boost_THREAD_LIBRARY})
# If user has explicitly specified flatbuffers lib then use that,
# otherwise search for it based on FLATBUFFERS_BUILD_DIR