aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorTeresa Charlin <teresa.charlinreyes@arm.com>2023-04-27 21:37:56 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2023-04-28 15:43:40 +0000
commitecebb0f321d996a276bfe79efd9c8bef25834a92 (patch)
tree7059bae882f3ba194135d62487473f7fee8f4686 /delegate/CMakeLists.txt
parent7f62346b0b399ff30213be8df7c175933298b242 (diff)
downloadarmnn-ecebb0f321d996a276bfe79efd9c8bef25834a92.tar.gz
IVGCVSW-7596 IVGCVSW-7619 IVGCVSW-7597 Pack, Unpack and Pad for opaque delegate
Signed-off-by: Teresa Charlin <teresa.charlinreyes@arm.com> Change-Id: I25415793497f0ee08d880539e265b133875a20f7
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index a77e630da0..081b3f32a0 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -292,6 +292,10 @@ if(BUILD_UNIT_TESTS)
test/LogicalTestHelper.hpp
test/NormalizationTest.cpp
test/NormalizationTestHelper.hpp
+ test/PackTest.cpp
+ test/PackTestHelper.hpp
+ test/PadTest.cpp
+ test/PadTestHelper.hpp
test/Pooling2dTest.cpp
test/Pooling2dTestHelper.hpp
test/Pooling3dTest.cpp
@@ -304,7 +308,9 @@ if(BUILD_UNIT_TESTS)
test/ShapeTestHelper.hpp
test/TestUtils.hpp
test/TestUtils.cpp
- test/TransposeConvolution2dTest.cpp)
+ test/TransposeConvolution2dTest.cpp
+ test/UnpackTest.cpp
+ test/UnpackTestHelper.hpp)
# Until all operators are supported, we have to add tests one by one above to opaqueDelegate_unittest_sources.
# After we add can add commonDelegate_unittest_sources to the add_executable below.