aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2023-04-26 15:58:39 +0100
committerFrancis Murtagh <francis.murtagh@arm.com>2023-04-27 17:27:09 +0100
commit3a9e7bac89a120fddaf3bcf312105258a840dab1 (patch)
tree381db8bb43e9fdfe822bdfe2bf44395cf8296dd1 /delegate/CMakeLists.txt
parentcfbb2717b21fec803839c478dde8292263fa4f45 (diff)
downloadarmnn-3a9e7bac89a120fddaf3bcf312105258a840dab1.tar.gz
IVGCVSW-7584 IVGCVSW-7585 Implement Conv3d and TransposeConv2d operators for opaque delegate
* Add check for TF version so tests work with opaque and classic Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Change-Id: I3a6699150afabfc6200e1cd4d264a1f7c65c5f60
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index f46119cf3a..4bb9bdd5de 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -272,6 +272,7 @@ if(BUILD_UNIT_TESTS)
test/ControlTest.cpp
test/ControlTestHelper.hpp
test/Convolution2dTest.cpp
+ test/Convolution3dTest.cpp
test/ConvolutionTestHelper.hpp
test/DepthwiseConvolution2dTest.cpp
test/ElementwiseUnaryTestHelper.hpp
@@ -289,7 +290,8 @@ if(BUILD_UNIT_TESTS)
test/PreluTest.cpp
test/PreluTestHelper.hpp
test/TestUtils.hpp
- test/TestUtils.cpp)
+ test/TestUtils.cpp
+ test/TransposeConvolution2dTest.cpp)
# Until all operators are supported, we have to add tests one by one above to opaqueDelegate_unittest_sources.
# After we add can add commonDelegate_unittest_sources to the add_executable below.