aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2023-04-27 11:48:26 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2023-04-27 13:27:58 +0000
commit0bd4c6230974e7e446cd26104180d520b643d5bb (patch)
treedcf5d8d6f78fbc22d2eed6f204398d99a4d8ab6c /delegate/CMakeLists.txt
parent0d2945394d6c3a08b906eeef4a16735dbf96c9c0 (diff)
downloadarmnn-0bd4c6230974e7e446cd26104180d520b643d5bb.tar.gz
IVGCVSW-7574 IVGCVSW-7590 IVGCVSW-7600 Implement Activation, FullyConnected and Prelu operators for Opaque Delegate
* Added missing headers to opaque/CMakeLists.txt (Control and Comparison) * Cleaned up Control.hpp headers. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I442edb9c467b515b130fbaf02879f0802006255f
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 06c317a03d..3914a24fb5 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -259,6 +259,8 @@ if(BUILD_UNIT_TESTS)
common/src/test/DelegateTestInterpreterUtils.hpp
opaque/src/test/ArmnnOpaqueDelegateTest.cpp
opaque/src/test/DelegateTestInterpreter.cpp
+ test/ActivationTest.cpp
+ test/ActivationTestHelper.hpp
test/ArgMinMaxTest.cpp
test/ArgMinMaxTestHelper.hpp
test/BatchSpaceTest.cpp
@@ -272,10 +274,14 @@ if(BUILD_UNIT_TESTS)
test/Convolution2dTest.cpp
test/ConvolutionTestHelper.hpp
test/DepthwiseConvolution2dTest.cpp
+ test/FullyConnectedTest.cpp
+ test/FullyConnectedTestHelper.hpp
test/GatherTest.cpp
test/GatherTestHelper.hpp
test/GatherNdTest.cpp
test/GatherNdTestHelper.hpp
+ test/PreluTest.cpp
+ test/PreluTestHelper.hpp
test/TestUtils.hpp
test/TestUtils.cpp)