aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSadik Armagan <sadik.armagan@arm.com>2020-02-10 12:24:15 +0000
committerSadik Armagan <sadik.armagan@arm.com>2020-02-10 14:08:54 +0000
commit3896b47a3532aadcde43a3e7fed760a0f4a29e6b (patch)
treea22d1b6d5b2df7518c9116dd48a7ca1990b3ae66 /CMakeLists.txt
parent03181ff73f4b37d2132f15c4bd229a148840cc15 (diff)
downloadarmnn-3896b47a3532aadcde43a3e7fed760a0f4a29e6b.tar.gz
IVGCVSW-4328 BufferManager running out of buffers crashes application
* Refactored SendCounterPacket classes, separated SendCounterPacket from Send thread * Created ISendThread.hpp, IConsumer, SendThread.hpp and SendThread.cpp * Injected IConsumer to BufferManager to notify SendThread when packet is ready to read Signed-off-by: Sadik Armagan <sadik.armagan@arm.com> Change-Id: I80f0bb8b8401c6bfd1611f7760217c6fe35d7ad8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763c07e275..d534c0a6d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -469,10 +469,12 @@ list(APPEND armnn_sources
src/profiling/Holder.cpp
src/profiling/Holder.hpp
src/profiling/IBufferManager.hpp
+ src/profiling/IConsumer.hpp
src/profiling/ICounterDirectory.hpp
src/profiling/ICounterRegistry.hpp
src/profiling/ICounterValues.hpp
src/profiling/ISendCounterPacket.hpp
+ src/profiling/ISendThread.hpp
src/profiling/IPacketBuffer.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
@@ -507,6 +509,8 @@ list(APPEND armnn_sources
src/profiling/RequestCounterDirectoryCommandHandler.hpp
src/profiling/SendCounterPacket.cpp
src/profiling/SendCounterPacket.hpp
+ src/profiling/SendThread.cpp
+ src/profiling/SendThread.hpp
src/profiling/SendTimelinePacket.cpp
src/profiling/SendTimelinePacket.hpp
src/profiling/SocketProfilingConnection.cpp