aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-10-22 11:07:45 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-10-25 16:07:45 +0000
commit830101c2debac8b3f22c048fad603f34b76bdca1 (patch)
treef398bcbd687503a79fcced3e34f0411f5864f94a /CMakeLists.txt
parent48623a0f6f4681ce0d9525b1587b7f96bfd58519 (diff)
downloadarmnn-830101c2debac8b3f22c048fad603f34b76bdca1.tar.gz
IVGCVSW-4022 Create a DeclareLabel utility function
* Created new TimelineUtilityMethods class * Created the DeclareLabel utility methods inside the new class * Added unit tests Change-Id: Ife0f7853a556d48206b76baeb3934344a990bee9 Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38605cac18..ac8b7e4264 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -495,6 +495,8 @@ list(APPEND armnn_sources
src/profiling/SocketProfilingConnection.hpp
src/profiling/TimelinePacketWriterFactory.cpp
src/profiling/TimelinePacketWriterFactory.hpp
+ src/profiling/TimelineUtilityMethods.cpp
+ src/profiling/TimelineUtilityMethods.hpp
third-party/half/half.hpp
)
@@ -626,6 +628,7 @@ if(BUILD_UNIT_TESTS)
src/profiling/test/SendCounterPacketTests.hpp
src/profiling/test/SendTimelinePacketTests.cpp
src/profiling/test/TimelinePacketTests.cpp
+ src/profiling/test/TimelineUtilityMethodsTests.cpp
)
if(ARMNNREF)